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1.1 Opening a Project and Client. 
 

From the File dropdown menu, select “Open Project/Client” (Fig. 1) 

 
Figure 1: File dropdown menu 

This action opens a new window, Fig. 2. 

 
Figure 2: Project/client navigation window 

Use the [Browse] button to navigate to the location of the Project dataset you want to open. Clients 
within that project will appear in the [Clients] window (red box, Fig. 2). If you want to automatically 
return to this project the next time you want to open a project, click on the [Set to default project root] 
button, which will maintain the folder location of your project in the [Project root] field. Click on one 
of the Clients and click on [Open].  

1.2 Resynchronisation, Field of View and Depth setÝngs 

1.2.1 Resynchronisation 
When you open the Client, you might receive a pop-up message to say that there is a synchonisation 
problem. If this did not happen, skip ahead to §2. If AAA says it is unable to synchronise the recording, 
this means that your UTI frames and audio are not synchronised for the current recording. It is likely 
that the recording channel designated as the synch signal channel in the software is different from the 
one the synch signal was recorded to. To fix this, identify the synch channel by clicking on each of the 
[Chan] radio buttons in the bottom right corner of the window, Fig. 3, until you find the synch signal, 
which should look like the example below.  
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Figure 3: Channel radio buttons and synch signal recording 

Now that you have established which channel is the synch channel. Right click on the UTI video pane, 
Fig. 4. Select [Ultrasonic Setup], then [Synch Recording] 

 
Figure 4: How to change the synch channel setÝng and resynch the recording 

You will see the dialogue pane below, Fig. 5. Make sure the correct channel is selected as the Synch 
Channel (red oval, Fig. 5), then press the [Synch] button. You only have to do this once, i.e. for the 
current recording. You will not have to resynchronise the whole recording session. When you opened 
the current recording, AAA synchronised the UTI frames and audio according to whatever signal was 
on the channel that was selected as the synch channel. Once you have selected the correct synch 
channel, AAA will correctly synchronise any subsequent recordings you open. 

 
Figure 5: Synch recording setÝngs 

1.2.2 Field of view and Depth setÝngs 
Field of view (i.e., fan angle) and Depth setÝngs should be visible at the bottom of the Ultrasound 
pane if your data were recorded with a Microsystem or EchoB system. Field of view is abbreviated on 
the Ultrasound pane to “FOV”. If you cannot see all these setÝngs, try moving the edges of the pane 
to increase your view (see §2 below). 
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2. Annotation and analysis 

2.1 The analysis tab 
The Client you selected will automatically open in the [Record Ultrasonic] task window, Fig. 6. Click on 
the [Analyse Ultrasonic] task window (red oval) to begin annotation and analysis.  

 
Figure 6: Record Ultrasonic view 

In the [Analyse Ultrasonic] task window, Fig. 7a, you can resize elements by clicking and dragging on 
their edges. You can also make these changes permanent the layout by right clicking on the bar on the 
very top of the task window and select [Design] (see Fig. 7b). Click twice on the shaded box tabs in 
each pane in the task window and they will “pop out”. Once you click on the cross in the top righthand 
corner, they will be removed from the task window.  

On the top left of Fig. 7a, you can see the UTI video pane. On the top right, you can see a list of 
recordings, multiple repetitions of a stimulus will appear in one row, each one as a small box with a 
cross in it. At the bottom of Fig. 7a, there is a spectrogram pane, and glossogram pane. The glossogram 
represents changing tongue position and height in the way a spectrogram represents changing patterns 
of acoustic energy. The top to bottom of the glossogram correspond to different midsagittal locations 
in the vocal tract: dental, alveolar, palatal, velar, pharyngeal. The colours represent tongue proximity 
to the upper vocal tract surface in these regions, with hot colours representing greater proximity than 
cool colours, see Fig. 7b. The glossogram can be selected by right-clicking on the spectrogram pane 
and selecting “glossogram”. However, to be able to view a glossogram, you are required to first fit DLC 
splines to the tongue surfaces for the recording (see §3.6).  

Below it, UTI key frames (thumbnails of UTI frames). The thumbnails are really only for you to eyeball 
the progress of the articulatory movements. Each small tick mark above these keyframes, represents 
the temporal point of a UTI frame, see Fig. 8. Check that these are evenly spaced and not bunched 
together, which would indicate a synchonisation problem. 
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Figure 7a: The Analyse Ultrasonic pane 

 
Figure 7b: Analyse Ultrasonic task window with glossogram selected. 

 
Figure 7c: Accessing the Design function to change the task window layout. 

 

 
Figure 8: A zoomed in view of the UTI-frame check marks and UTI image thumbnails. 
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2.2 Playing sound/UTI video recording and navigating 
To play the whole recording, press the [Play] button on the bottom left of the pane, Fig. 9. To slow play, 
right-click on the play button, and select a slow-play option. 

 
Figure 9: Sound/UTI video play options 

To play a portion of the recording, click and drag across the waveform window (not the spectrogram) 
to select part of the audio file, Fig. 10, then click [Play]. To zoom in to your selection, right-click on the 
waveform (not the spectrogram) of the selected portion and click on [Zoom]. To zoom out again, double 
click on the waveform window. 

 
Figure 10: Selecting a portion of the recording to play.  

2.3 Adding annotations 

There are two types of annotation you can add to each recording. Point annotations, or interval 
annotations. Add a point annotation by clicking on the desired location on the wave-form pane and 
clicking on the [Add] button, see red rectangle Fig. 11. In the [Label] field, type the name of your 
annotation. In the [Key] field, add keywords with spaces between each to help you filter your 
annotation. You can also export key words with your annotation data for later analysis, i.e. as a tab 
separated .txt file that can be opened in Excel. In the example below, Fig. 11, I have annotated the 
temporal maximum of the tongue root gesture. The key words indicate that the sound occurred in a 
syllable coda, that it was in a medial position in a phrase and that the stimulus word was “bar”. You will 
want to make sure your keywords are always added in the same order, so that they all appear in the 
same column in the excel spreadsheet. 

To add an interval annotation, simply click and drag across the area you want to annotate and click the 
[Add] button. Then add text to the [Label] field and optional key words. You will see in Fig. 11, that 
both annotations are shown on the waveform pane. The point annotation, as a red and yellow 
diamond, and the interval annotation as a horizontal red line, beginning and ending with yellow 
triangles. 
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Figure 11: Adding an annotation label and keywords 

2.3.1 Filtering annotations 
In the box above the wave form, blue rectangle in Fig. 11, you will see a list of annotations followed by 
details of the recording they belong to. If there are lots, you will see a scroll bar on the right-hand side, 
so that you can navigate to specific annotations. You can filter these annotations to obtain a subset of 
annotations across a single Client, or across multiple Clients in the same project. By clicking on the 
annotation, you will automatically be taken to that annotation in a new recording, and perhaps a 
different Client, than the one that is open. To make sure you don’t move to a new Client, make sure 
you select [Current Client] in the steps set out below. 

To create a filtered list of annotations, click on the [Filter] button, green rectangle, Fig. 11. 

A new pop-up window will appear with multiple tabs, as in Fig. 12 below. 

 
Figure 12: Annotation filtering options, different tab views. 

In the Client tab, select to filter annotations in the “Current Client”, or “All Clients” in the project.  

In the Recording tab select, (i) Current Recording, (ii) All Recordings, or (iii) Filter on Recording – with 
this option, you can filter by Prompt, Session Name, or Recording Date 

In the [Annotation] tab, you can filter by (i) Label, (ii) Notes or (iii) Keywords. With keyword filtering, 
you can use Boolean logic, e.g.  coda AND/OR onset NOT medial. 

If you select [RegExp] (see last panel in Fig. 12) you can use Regular Expressions for a more powerful 
way of searching your keywords.

In the Sort tab, you can sort by various aspects of metadata, e.g. Date, Client, (annotation) Label, 

Prompt etc. Click [OK]  
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The final filtered list will appear in the annotation box, see blue rectangle, Fig. 11. 

 

N.B. Once you have filtered annotations, any annotations that were not selected by the filter will 
disappear from the waveform pane. To see them again, remove all filters using the filter options dialogue 
box. If you think that annotations you made previously have disappeared, there is probably an annotation 
filter setÝng that needs to be removed. 

2.3.2 Exporting annotation data 
You can export annotations as a Praat TextGrid, or export annotation data with e.g. temporal 
information about where the annotation occurred in the recording. 

To export your annotation data, go to [File]>[Export]>[Data], see Fig. 13. 

 
Figure 13: Steps to export annotation data. 

The Export pop-up window, Fig. 14, contains a number of tabs. In the Export File tab, check the 
“Export to file” box and [Browse] to the folder location where you want to export file to be saved. 

 
Figure 14: Export pop-up window; export file tab view. 
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In the [Filter] tab, select [Export Annotations] (red rectangle, Fig. 15). Then click on the [Change Filter] 
(blue rectangle, Fig. 15) button to filter to the annotations you want to export. 

 

 
Figure 15: Export pop-up window; filter tab view. 

In the [Rows] tab, Fig 16, select the [Data values] tab. Select the [Single point select] (red rectangle) 
and check the [Add column headings] box (blue rectangle). 

 
Figure 16: Export pop-up window; rows tab view, data values 

Then select the [Data summary] tab (red rectangle, Fig. 17) and under the heading [Write Data] select 
“Just write data”. 
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Figure 17: Export pop-up window; rows tab view, data summary 

In the [Columns] tab, Fig. 18, you can select the metadata and data you want to appear in your exported 
dataset and what order they appear in. Click on one of the (meta)data item buttons on the top right 
(see red rectangle, Fig. 18) and click [Add]. Probably best to start with Client; Prompt; Annotation, 
then Time.  When you click on the [Time] button, a submenu will appear asking you to specify what 
time item you would like to export. Select “sample time of row within recording”. 

 
Figure 18: Export pop-up window; columns tab view. 

Click the [Execute] button. 

You will be able to follow the export process via the progress bar along the bottom of the pop-up 
window and an annotation count in a box on the right-hand side of the pop-up window. Exporting can 
take a while, particularly if you are exporting annotations from an entire Project. When the export 
process is finished, you have the option to view the exported annotation data in table format. Click 
[yes] or [no].  Your annotations will be exported as a .txt file, which can then we opened in Excel, Fig 
19. This is just for eyeballing, a .txt file of this information will have been saved in the directory location 
you selected; however, eyeballing this file gives you a quick way to see if your export worked properly 
or not, or whether you need to change your setÝngs and re-run the export. 



12 AAA workshop 2023 

 
Figure 19: Excel spreadsheet of exported annotation data, including key words and annotation times within the recording. 

2.3.3 Exporting/importing annotations as Praat TextGrid with audio files 
To export annotations as Praat TextGrids, go to [File]>[Export]>[Files…], see Fig. 20. 

 
Figure 20: Exporting annotations as Praat TextGrid files. 

In the pop-up window that appears, Fig. 21. Select the [Files] tab. Under [Filename] add a stem for 
your TextGrid file names. Under [Write Files] browse to the location where you want the TextGrid 
files saved. Then click on the button [Select Clients/Sessions to Export].  

In the pop-up window that appears, checking the box next to a Client’s identifier will make other tabs 
appear. Click on these tabs and manually check the items that you want to export as TextGrids. There 
will be an option to “Select all” if you want to select every item in a session, but you may not want to 
export, e.g. an initial swallow, or bite plane recording, so you could uncheck just those boxes. 
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Figure 21: (left) Export files popup, Files tab, (right) Select Clients popup allowing you to select specific clients’ sessions and 
recordings for export. 

To batch export the audio files associated with annotations, select the [WAV] tab, red rectangle Fig. 22. 
Check the “Export WAV” box, and the radio button next to “Export Individual Channels as Separate 
*.wav file”. Make sure to select the channel with the audio recording on it (below it is Channel 2, but 
it might be different for your dataset). I always delete the text string in the Postfix column (see yellow 
highlighted section in Fig. 22), as it is not particularly helpful, and it will give your .wav file a different 
name from the TextGrid, which will require an extra scripting step if you want to automatically process 
the .wav file and the TextGrid file with a Praat script. 

Select the [Annotations] tab, red rectangle Fig. 23, then check the box that says “Export Annotations 
as PRAAT Format”. Click on the [Splines], and other, tabs and make sure all of the boxes are 
unchecked. Then click on [OK]. 

 

 

Figure 22:  Export files popup, WAV (audio file) tab.  
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Figure 23:  Export files popup, Annotations tab. 

A (i) .wav file, (ii) .TextGrid file and a (iii).txt file containing recording filenames and annotations will 
be added to the directory you selected. I selected only one recording for export, so only 3 files 
appear in my selected folder, Fig. 24. 

 
Figure 24:  Exported .wav file and Praat TextGrid file. 

Open Praat and select [Open]>[Read from file]. Select the .wav file and TextGrid to load them to the 
Objects window, then select both and click [Edit] to open them together in the Editor window, see Fig. 
25. You will see that, in this case, both a point and an interval tier have been created for point and 
interval annotations. 
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Figure 25: .wav file and TextGrid file exported from AAA, opened in Praat. 

You can also import .TextGrid files, e.g. you may wish to add some articulatory annotations with AAA 
and some others automatically with a Praat script, based on the audio file. Click on [File]>[Import]> 
[TextGrid]. You will be asked to navigate to the folder where the TextGrids are stored. It is important 
that the .txt export file containing exported data information is present in this folder. Click [OK]. You 
will be asked to verify the files you want to import annotations for by checking or unchecking the boxes 
next to them, then click [OK]. You will be asked to keep, or delete, recordings on a recording-by-
recording basis. There are also keep or delete “all” recordings options. Select to “delete (all) recordings” 
to avoid duplicating existing annotations. 

3. Adding splines to a palate trace, bite plane trace, tongue surface and creating 
Client spline templates 
There are two ways of adding tongue splines. The older “fan-based” method is described here. The 
knots of the tongue (and other) splines are constrained to lie on one of 42 radial fan axes with an origin 
in the ultrasound probe. Fan-based splining involves manually fitÝng reference splines (Roof and 
MinTongue), which limit the locations where AAA will search for a bright tongue surface, then using 
edge-detecting functions in AAA to automatically identify the tongue surface, followed by manual 
correction and removal of the tongue spline beyond the tongue’s surface.  

The newer method of adding tongue splines is called Deep Lab Cut (DLC) and is explained in section 
3.6. DLC has numerous advantages over the fan-based fitÝng method; it requires less manual 
intervention; it is more accurate; substantially faster; the splines are unconstrained and therefore fit 
more closely to the tongue’s surface, and the shape of the tongue root in the DLC splines is a more 
accurate representation of the tongue root.  

It is still important to know how to manipulate individual tongue splines in case you want to manually 
fix something. Learning how to trace the palate and a bite plate can also be important for some 
analyses, or for video presentation of UTI recordings. We have included both the fan-based and the 
DLC methods in this tutorial.  

3.1 Adding fan-based splines 
To begin adding fan-based splines to Ultrasound keyframes, right-click on the Ultrasound pane and 
select [Edit Splines], see Fig. 26. 
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Figure 26: GetÝng to the spline editing window. 

When the Edit Spline window appears, click on the [New] button and select “Current recording fan”, 
see Fig. 27. 

 
Figure 27: Choosing a fan template. 

If you click on the [Splines] tab on the Edit Splines window, you will see splines are available, e.g. see 
red rectangle, Fig. 28 - (i) Roof (default colour green) (ii) Tongue (default colour red) (iii) Min tongue 
(default colour white). You can make each spline “active” by clicking on its tab, see red rectangle, Fig. 
28. The default colour of the “active” spline will change to orange, and you will see 42 intersecting 
tick marks, or knots, along the length of the spline. You can also make the spline thicker or change its 
colour while it is active on the Edit Splines pane; however, the green, red, and white colours are 
conventional with AAA use. 
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Figure 28: Selecting different splines 

The “active” (coloured orange) spline will automatically move to the position of your cursor on the 
ultrasound window. If you want to remove part of the spline, hold down [Ctrl] on your keyboard while 
you click and drag your cursor. You will see the solid line disappear and be replaced by a series of dots, 
see Fig. 29, left. When you deselect the spline by clicking on a different spline tab, you will see that the 
section represented as dots is no longer visible, see Fig. 29, right. 

 
Figure 29: Moving the active spline and removing parts of it. 

To fit the roof to the palate trace, click and drag your cursor across the bright palate surface. You can 
adjust parts of the spline by clicking on the spot where you want it to go. Remove the spline to the 
right of the alveolar ridge by holding down [Ctrl] while you click and drag. Remove any of the palate to 
the left of your estimation of where the hard palate ends. The soft palate is mobile and will be in a 
different position during speech, so won’t serve as a good reference marker. 

The Roof and Min Tongue splines provide limits for automatic tongue-spline fitÝng. The job of the Min 
tongue spline is to exclude all of the bright structures close to the probe (mostly chin fat) and the short 
tendon (circled in red, Fig. 30), that would distract the automatic fitÝng process from the tongue 
surface. 

 
Figure 30: SetÝng the Palate and Min tongue splines 

3.2 Adding a fiducial spline to the bite-plane trace 

Fiducial lines can be used as axes, to track and plot tongue or lip movements (Lawson et al., 2019). 
They can be placed anywhere on the ultrasound pane. Additionally, they can be used to identify the 
occlusal “bite” plane if you collected a bite-plane trace. To add a fiducial, click [New Spline] and select 
“Fiducial line” from the dropdown menu, see Fig. 31, left. An active orange line will appear. Click and 
drag on the orange boxes at each end of the line to manoeuvre it into position. The vertical, protruding, 
orange dotted line is to make sure the fiducial is in the right orientation. This is crucial if you are using 
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a fiducial line to take measurements, e.g. measuring how far along the fiducial line another spline or 
fiducial intersects. In the [Name] dialogue box, rename the spline e.g. “Bite”, or “Fiducial”. 
Conventionally, the bite-plane trace is coloured pale blue. 

              
Figure 31: Adding a fiducial line to the ultrasound pane to represent the bite-plane trace. 

3.3 Making a fan-based spline template 
Now you have your reference splines in place, you can save them as a template for that particular 
Client-recording. Click on the [Template] tab of the [Edit Splines] window, see Fig. 32. Check the boxes 
of all the splines you want to include in your template and click [Save to File]. Save the template to 
your AAA folder and give it the name of the dataset, client and recording session. The template will 
have the extension .bst. These template files can be copied into other folders, so if you download a 
new version of AAA, or pass your dataset onto another researcher, you can move the templates into a 
new AAA folder, and they will be available to use. If you want to use a Client spline template, rather 
than one of the existing AAA templates, when you click on [New Spline], see Fig. 31, select “From 
template” and a list of existing Client templates that you have created will be available to be selected. 

 
Figure 32: Saving a Client spline template 
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3.4 Adding keyframes 
Keyframes correspond to UTI frames, but they allow splines to be overlayed on the ultrasound image. 
Keyframes have to be manually added to each recording for each spline type (Roof, Tongue, Min Tongue 
etc.). Usually, we only add multiple keyframes for the tongue spline, as the other “landmark” splines 
(Roof, Bite plane, Min tongue) are not expected to move. When you add a spline template to a 
recording, AAA will automatically create one keyframe for all splines (Roof, Tongue, Min Tongue etc.) 
at the beginning of the recording. In order to add splines to subsequent UTI frames, you must manually 
add those key frames.  

Important! Make sure that you have selected the Tongue spline tab (see Fig. 33, blue rectangle) before 
adding more keyframes. 

 

You can add a single key frame by positioning the cursor at a specific temporal point on the wave-form 
pane, e.g. at the timepoint of a point annotation, by selecting “single keyframe” in the Keyframes tab, 
see red rectangle in Fig. 33, and clicking on [Add]. Or you can add keyframes to a region of the 
recording, by clicking and dragging across a section of the wave form and selecting “Every Nth video 
frame” and selecting the value of N. Adding a key frame to every single UTI frame will take up more 
processing time and may not be necessary. Then click the [Add] button. 

 
Figure 33: Adding keyframes 

The temporal location of keyframes is indicated on the ultrasound showreel/thumbnails at the bottom 
of the Analyse Ultrasonic pane, on top of the ultrasound frame tick marks. The keyframe tick marks are 
a different colour (red or cyan). You will also see a list of keyframe timestamps under the [Keyframes] 
tab in the Edit Splines window, see blue shaded area in Fig. 34. You can click on each of these 
timestamps to go to a particular frame, or select multiple frames by clicking on the first frame in the 
list and hold [Shift] + clicking on the last frame in the list. You can delete a keyframe, or multiple 
keyframes, by select them and clicking on the [Delete current keyframe] button. 
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Figure 34: Selecting and deleting keyframes. 

If you created an initial keyframe and fitted splines to the palate and bite-plane trace, then these fitted 
splines will appear in all subsequent keyframes you created. 

3.5 Automatic tongue-spline fitÝng 
To automatically fit a Tongue spline over multiple keyframes, you need to manually fit the Tongue spline 
to the tongue’s surface in the first keyframe in the sequence. You can do this roughly by clicking and 
dragging across the tongue’s surface. In the [Fit Spline] tab, see blue rectangle in Fig. 35, look for the 
[Keyframes Region] section of the window, and select “Current time only” (black X, Fig. 35), and in the 
[Autofit method] section, select “Snap-to-fit” (red cross, Fig. 35). From experience, this is the most 
accurate fitÝng option. Then click the [Process this Recording] button. The Tongue spline position will 
automatically be adjusted in the initial keyframe in the sequence. 

 
Figure 35: FitÝng and adjusting a Tongue spline 

Once you have accurately fitted a Tongue spline to the tongue’s surface in the first keyframe in the 
sequence, you can select the remaining keyframe timestamps by clicking on the first timestamp and 
hold [Shift] + clicking on the last, so that they are all highlighted in blue (see Fig. 36). Under [Keyframes 
Region] select either “All of recording”, or “Select(ion) of recording” (see black cross, Fig. 36), 
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depending on how many keyframes you have added, then select the “Track” option under [Autofit 
method], red cross, Fig. 36. Then click on the [Process this Recording] button, red rectangle, Fig. 36. 

  
Figure 36: Automatic Tongue spline fitÝng over multiple keyframes 

Tongue splines will be automatically fitted to all frames; however, manual correction of the tongue 
spline will be required in each keyframe to varying extents. If you notice a frame where the fitÝng is 
very inaccurate, you can manually fit the tongue Spline for that keyframe, then select the keyframe 
and all subsequent keyframes and use the Track fitÝng function again to see if you get better results. 
You can also use the Track Back function. You may also want to go through the keyframes and manually 
remove sections of the Tongue spline that do not correspond to a tongue surface, e.g. beyond the 
tongue tip. 

3.6 Tongue spline fitÝng using Deep Lab Cut (DLC) MD 
To use the Deep Lab Cut (DLC) (also known as 2D spline) spline-fitÝng function, right click on the 
ultrasound image. On the menu that appears select [Edit splines]. On the window that appears, select 
the tab [Fit Spline]. Tick the “DeepLabCut” method. Then move to the [Batch] tab, shown in Fig. 37, 
and then the [Choose recordings] subtab. Ensure that the recording(s) selected for processing is the 
right one. If not, use the [Change filter] option, as explained earlier, to select your chosen recordings. 
If you only want to fit splines to single point annotations or annotated regions (interval annotations) 
of the recordings, you can use the filter in [Choose Recordings] to select the annotations you want to 
add splines to. However, if you have point (rather than interval) annotations, you will have to uncheck 
the box “Align to ultrasonic frame” in the [Key Frames] tab (see Fig. 37b). 

Once you have selected the recordings, or annotated sections that you want to add splines to, open 
the “Process batch” tab and tick the three boxes next to “DLC_Tongue”, “DLC_HyoidMandible”, 
“DLC_ShortTendonMandible” and press Process. The DLC_HyoidMandible and 
DLC_ShortTendonMandible are necessary to create glossograms (see §2.1). If the tongue tip in your 
recording is pointing to the left (not the standard), then you have the option to specify this before you 
process the recording via the menu “Tongue Tip is pointing:”. Selecting the “Monitor Progress” option 
may significantly slow down the tongue splining process.  

Although it is much less likely that you will have to manually correct DLC splines than fan-based splines, 
you can still correct DLC spline positions by clicking and dragging on the knots (the small orthogonal 
lines intersecting the tongue spline). Make sure that the DLC_Tongue spline is selected by clicking on 
its tab. Once it is active, it will be coloured orange, the knots will be visible and they can be moved. 
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Figure 37b: Unchecking “Align to ultrasonic frame” in order to be able to add DLC splines to single frames associated with 
point annotations.

 

Figure 37a: The Edit Splines menu for using Deep Lab Cut.
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3.6.1 Converting fan-based splines to DLC splines and vice versa, and other spline batch 
processing 
 

3.6.1.1 Converting splines 
Technically, you should be able to convert DLC splines to fan-based splines and vice versa. You can do 
this by opening up the Spline Editor and clicking on the [Batch] tab. Then click on the [Change Splines] 
subtab. Select the splines you want to convert and click on [Change all]. In practice, this might not work 
very well. At least for conversion of fan-based splines to DLC, it might be more practical to delete 
existing splines (see §3.6.1.2 below) and then add DLC splines from scratch. 

3.6.1.2 Other batch processes for splines; hiding and deleting splines 
Other useful types of batch processing for splines can be accessed via the [Batch] tab and the [Change 
Splines] subtab of the Spline Editor. You can check the boxes to “Hide all splines” or “Show all splines”, 
or “Delete all splines”. Additionally, you can select to hide just the tongue spline etc. by checking the 
appropriate boxes. There is a bug in V221_2_0 whereby you must click on any other tab in the Edit 
Splines window before clicking on the batch tab, otherwise the batch process will not occur. Alan 
Wrench is aware of this bug. 

3.7 Exporting splines to the workspace and publisher 

3.7.1 Exporting splines to the Workspace using Edit Splines 
The Workspace allows you to compare the position and shape of tongue splines regardless of when 
they were temporally recorded. It also allows you to carry out some basic functions such as rotating 
and translating splines, or groups of splines, and creating mean tongue surfaces with standard 
deviations. 

To export a spline, or splines, to the workspace, select the keyframe(s) timestamp of the spline(s) in 
the [Keyframes] tab of the “Edit Splines” window, then click on the [To Workspace] button (red 
rectangle, Fig. 38), under the “Copy Spline” section of the Edit Splines window. 

 
Figure 38: Transferring splines to the Workspace 
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3.7.2 Exporting splines to the Workspace using the Export function 

You can also export splines to Workspace by selecting relevant annotations using the filter function. 
Exit the Edit Spline window. Then go to File>Export>Data. In the pop up, select [Export to Spline 
Workspace] and unselect [Export to file]. Then click on the Filter tab and go through the same process 
of choosing which splines you want to export, as explained earlier, then click on the [Splines] tab and 
tick the box next to “Tongue”. Press [Execute] and the Spline Workspace window will appear with the 
exported splines in it.  

You can click on the keyframe timestamps on the lefthand pane (see Fig. 39) and see the selected spline 
emboldened in the group. You can hide a spline from view by clicking on it on its timestamp and then 
unticking the box next to “Visible” in the bottom right corner. You can delete a spline by selecting its 
timestamp and then clicking on [Delete] in the bottom right corner.  

If you close or minimise Spline Workspace and can’t get back to it, right-click on the ultrasound image 
and select the option “Spline Workspace” or use the File dropdown menu and select “Spline 
Workspace”. 

 
Figure 39: A view of Spline Workspace 

You can save your workspace file by clicking on the [File] tab of the spline workspace, then save the file 
to a location. The file type for a workspace file is .wsp. You can also load a previously-saved workspace 
file using the [open file of splines] button. 

3.7.3 Exporting splines to Publisher 
To produce figures for your papers and presentations, you might want to use Publisher. Once you can 
see your list of splines on the Spline Workspace, highlight the ones you want to use for figures by 
clicking and dragging across their timestamps in the left-hand pane. In the bottom-right corner click on 
Copy to Publisher. The Publisher pop-up window will appear, see Fig. 40. 
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Click on Axes>Tie Plots to Axes>x-y axes. This correctly scales your image. You can adjust the names 
and values of the axes by editing the corresponding fields at the bottom. You can adjust the thickness 
and colour of the spline by clicking on the spline timestamp in the left-hand pane, then click on 
Plot>Colour, or Plot>Line>Width. While the spline is selected (or active), it will be orange, which is the 
default colour for active objects in AAA. You need to click on a different spline, or the Axes, to view the 
spline with changes implemented. You can adjust the font and size of the axes’ labels by selecting them 
in the right and then clicking on Plot>Font. You can add text titles and labels to your plot by clicking on 
the [Shape] menu and selecting “Create text”. Text can be dragged to the correct location. Font and 
size can be altered using the [Plot]>”Font” menu item.  

 

Please note that in AAA version 221.1.0 there is a bug where text items are not visible. The software 
developer is aware of this bug. Hopefully, it will be corrected in future versions of AAA. 

Save the publisher file, in case you want to make adjustments in another session. Click on File>Save as 
PUB file. The file extension will be .pub. 

You can save the figure you have created as a publishing-quality image file.  Click on File>Save as Bitmap 
and select the image dimensions. I recommend using the highest resolution. 

3.8 Batch exporting videos 
Exporting videos can be useful if you want to use them in a presentation for illustration, or for AI 
processing. 

To batch export videos go to [File]>[Export]> [Data], see Fig. 41 

 

Figure 40: A view of Publisher. 
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Figure 41: GetÝng to the Export window. 

In the Export window, click on the [Export File] tab, under [Name of Export File], browse to the location 
where you want the .avi video files to save. 

 
Figure 42: The Export window. 

To export only the annotated sections of the recording, under the [Filter] tab, click on the [Change 
Filter] button and filter on annotations, see Fig. 43. 

 
Figure 43: Choosing the correct annotations. 

Under the [Rows] tab, click on the [All ultrasonic frames] button, see Fig. 44. 
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Figure 44: Choosing the frames to export. 

In the [Columns] tab, click on the [Add] button (red rectangle, Fig. 44), then click on the [Ultrasonics] 
button (blue rectangle, Fig. 45). Then click on the radio button next to “Avi annot. Recording” (green 
rectangle, Fig. 45).  Under “Choose what text will be written for each line of the export file”, you will 
see a line called “Avi recording of ultrasonic data”. The other metadata items you add to this list will 
not affect the videos that are generated, but they will be exported as a .txt file that can be used to 
meaningfully rename your ultrasound video files. Unfortunately, the name automatically given to each 
.avi file generated is created from time stamps and will just be a series of numbers. However, if you 
also export selected metadata items like “Client name” and “Annotation label”, there are various ways 
you can automatically rename your video files once they are exported, e.g. with a renaming script or 
via the command window. Finally, make sure that you have specified what channel the sound is 
recorded on, (yellow rectangle, Fig. 45). Then click the [Execute] button. 

 
Figure 45: Columns setÝngs in the Export window, for batch exporting ultrasound video. 

A popup window will appear that lets you specify frame rate, video speed, whether splines and fans 
will appear on the video in the [Show] box (see red rectangle, Fig. 46, check boxes to include those 
items), and what the video will contain, e.g, spectrogram, waveform etc. (these can be dragged from 
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the right-hand box into the left to be included in the video). Likewise, items not needed can be dragged 
out of the [Show] box back to the list on the right. Video dimensions can also be changed. Then click 
[OK]. 

N.B. the “video” item refers to e.g. lip camera video that might have been recorded on a separate 
channel, not ultrasound.  

 

Figure 46: SetÝng video specifications.

Finally, the following dialogue box will appear for you to select the video compression codec, see Fig. 

47. Microsoft Video 1 is reasonably reliable. Then click on [OK]. 

 
Figure 47: SetÝng video compression codec. 

N.B. The video width setÝngs are crucial if you intend to use a compression codec. Ideally, use width 
720 and height 540 as above, or dimensions with the same width to height ratio, otherwise the 
resulting video will be unplayable.
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3.8.1 To export a single video
To export a single video, select the region of the recording you want to export, right click on the 
Ultrasound pane and click on [Make Movie…]. This will take you to the window as in Fig. 46. Under 
filename, browse to the location where you want the video to save and give the video a name. Change 
the setÝngs as you wish, e.g. frame rate, speed, video content etc. Click [OK], select a compression 
codec as in Fig. 47 and click [OK].

4. Spline analyses 

4.1 Mean and Standard Deviations in Workspace 
To find the mean and standard deviation of a set of tongue splines in Workspace, select all the 
timestamps of the splines on the left pane of Workspace by clicking and dragging. Click on the 
Functions tab in the bottom right corner of the Workspace screen. If you are using it with fan splines, 
which were added the traditional way, click on the [Fan spline Mean & Standard Deviation] button (red 
rectangle, Fig. 48). If you are using DLC splines, click the [2D Spline Mean & Standard Deviation] button 
(blue rectangle, Fig. 48). The latter option is only available in the currently latest version [V221.2.0]. 

Figure 48: Creating a mean tongue-surface contour with standard deviations. 

The new average spline and the SD outlines should pop up at the bottom of the timestamps list on the 
left side (see red rectangle, Fig. 49a). However, the mean tongue contour will probably be obscured by 
all the other splines. To view just the mean tongue contour, select all the other contours and uncheck 
the [Visible] box in the [Options] tab. You will then see only the mean tongue contour with its standard 
deviations (Fig. 49a). 
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Figure 49a: Workspace showing a mean fan-based tongue contour +/- one standard deviation for 41 splines fitted to the 
tongue during the maximum of an /r/ gesture. 

For the mean DLC spline, +/- standard deviations look different. Standard deviations are represented 
as 2-D ellipses around the mean tongue spline knots, see Fig. 49b. A mean tongue surface can be 
obtained by clicking on the [2D Spline Mean & Standard Deviation] button. 

 
Figure 49b: Workspace showing a mean DLC tongue contour +/- one standard deviation for the 11 knots fitted to the 
tongue during the maximum of an /r/ gesture. Standard deviations are represented as 2-D ellipses around the mean knots. 

 

4.2 t-test between splines (fan-based and DLC) 
To calculate the difference between the two phonemes, or lingual variants, such as syllable-onset and 
coda /r/ variants in Fig. 50a below, select the timestamps of the two mean splines by clicking the first 
and then ctrl+clicking the second. Click on the [Functions] tab in the bottom right corner of the 
Workspace screen. Then if you are using traditional fan splines, click on the [Fan Difference] button 
(blue rectangle, Fig. 50a). If you are using DLC splines, click the green [2D difference] button (blue 
rectangle, Fig. 50b). Click on the item called “DifferenceFanDists….” in the left-hand list of items and 
the numerical differences should be displayed in the Spline workspace, with individual measures 
(corresponding to the 42 radial fan lines for fans splines) displayed in the top right corner of the Spline 
Workspace. Regions of significant difference between tongue surface contours will be identified with 
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asterisks. To obtain differences between two mean DLC tongue surface contours, click on the [2D 
difference] button, blue rectangle, Fig. 50c.) 

Figure 50a: Workspace showing two mean fan-based tongue contours +/- one standard deviation and how to obtain the 
difference between tongue contours. 

Figure 50b: Showing the difference measure between two tongue curves. 

 
Figure 50c: Workspace showing two mean DLC tongue contours +/- one standard deviation, shown as 2-D ellipses around 
each of the 11 knots. 
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4.3 Number of INFLections (NINFL)  
One measure of tongue shape complexity is Number of INFLections (NINFL). NINFL is the sum of 
concave and convex inflections along the tongue spline which exceed a specific pre-programmed 
threshold. NINFL in AAA is implemented using Preston et al. (2019)’s procedure with some small 
modifications (see Dokovova et al., 2023). The NINFL formula was adapted to AAA assuming the 
presence of one curve along the tongue spline, so an output of 0 is equivalent to 1 in the original 
formula, so before analysing the output you need to add 1 to your results. According to the original 
implementation of NINFL, values over 5 are not to be used for analyses. 

To measure NINFL in AAA, you need your ultrasound images to have splines (see earlier steps). Open 
the Analyse Ultrasounic view (second tab along the top ribbon) if you are not already there. Then move 
your mouse over the fields under the spectrogram and right click, select “Edit charts”. A new window 
will appear, see Fig. 51. On the right-hand side select Spline (because NINFL is a spline-based measure). 
In the pop-up window, write the name of your new analysis value – NINFL – and click OK. 

 
Figure 51: Analysis values window with a pop up where you can name the analysis you will carry out. 

In the middle part of this window choose the [Shape] tab, see Fig. 52. Under “Shape measurement” 
you will see multiple analysis options. Select “NINFL". If you created splines using the traditional 
method with key frames, you can now press “Close” in the bottom right corner. If you created splines 
using the DLC method, navigate to the field under all the “Shape measurements” where it says 
“Tongue”. Open the drop-down menu by pressing the little arrow next to “Tongue” and select 
“DLC_Tongue”. Then press “Close” in the bottom right corner.  
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Figure 52: Analysis values window showing Spline-specific analyses (selected on the right menu) and specifically 
Shaperelated analyses (selected in the middle tabs). 

This brings you back to the [AnaVal Axes] window, see Fig. 53. Tick the box on the left of your newly 
created “NINFL” analysis to make it appear in your main AAA window under the Spectrogram, then 
click the small button with black arrows pointing up and down at the same time. This adjusts the 
minimum and maximum values in your display, which you can also do manually by editing the numbers 
in the field. Close the [AnaVal Axes] window by pressing “x” in its top right corner. You should now see 
a jagged line at the bottom of the main window. It represents the NINFL across time. Because NINFL 
values are integers, the line may have sharp corners and flat plateaus. In a following section it will be 
explained how to export the data. 
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Figure 53: Analysis values axes window where you can adjust the y-axis min and max values, which will show your analysis 
results under your spectrogram. 

4.4 Dorsum Excursion Index (DEI)  
Another measure of tongue shape is the Dorsum Excursion Index (DEI). This measure of tongue dorsum 
bunchiness was developed by Zharkova (2013) who defines the location of the tongue dorsum as 
“opposite the midpoint of the straight line traced between two ends of the midsagittal tongue curve” 
(p.485) (see Figure 54 below). DEI is calculated by measuring the length of line n, which connects the 
two ends of the midsagittal tongue curve, and the length of the perpendicular line d, which connects 
the midpoint of n with the tongue curve. Then the length of d is divided by n, which gives the value of 
DEI. Flatter tongue shapes have lower DEI and tongue shapes which are more bunched at the tongue 
dorsum have higher DEI. 

  
Figure 54: Example tongue splines for calculation of dorsum excursion index. Blue = /k/, Green = /t/, red = [q], with the 
tongue tip to the right. A line, n, is drawn between the ends of the spline and the midpoint found. A perpendicular line, d, 
is drawn and the dorsum excursion index is calculated as d/n. DEI values are green = 0.34, blue = 0.49 and red = 0.54. Copied 
from Cleland et al. (2023).  

To measure DEI in AAA, the process is similar to measuring NINFL. You need your ultrasound images to 
have splines (see earlier steps). Open the [Analyse Ultrasounic] view (second tab along the top ribbon) if 
you are not already there. Then move your mouse over the fields under the spectrogram (avoid the ones 
with existing analysis values in them) and right click, select “Edit charts”. A new window will appear, see 
Fig. 51. On the right-hand side select Spline (because DEI is a spline-based measure). In the pop-up 
window, write the name of your new analysis value – DEI – and click OK. 
In the middle part of this window choose the “Shape” tab. Under “Shape measurement” you will see 
multiple analysis options, see Fig. 52. Select DEI. If you created splines using the traditional method 
with key frames, you can now press “Close” in the bottom right corner. If you created splines using the 
DLC method, navigate to the field under all the “Shape measurements” where it says “Tongue”. Open 
the drop-down menu by pressing the little arrow next to “Tongue” and select “DLC_Tongue”. Then 
press “Close” in the bottom right corner. 

This brings you back to the [AnaVal Axes] window, see Fig. 53. Tick the box on the left of your newly 
created “DEI” analysis to make it appear in your main AAA window under the Spectrogram, then click 
the small button with black arrows pointing up and down at the same time. This adjusts the minimum 
and maximum values in your display, which you can also do manually by editing the numbers in the 
field. Close the [AnaVal Axes] window by pressing “x” in its top right corner. You should now see a 
jagged line at the bottom of the main window. 

4.5 Mean Nearest Neighbour Difference (mNND) 
The Mean Nearest Neighbour Difference (mNND) is an algorithm which finds the shortest distance 
between each point from a set of points (in our case a tongue spline) and all other points from another 
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set (in our case another tongue spline) and then calculates an average value based on these measures. 
In ultrasound tongue imaging it has been used to measure coarticulation (Zharkova & Hewlett, 2009) 
and tongue shape variability in a clinical and non-clinical population (Smith et al., 2023). 

To measure mNND in AAA, you need to have annotated key frames and have created splines for them. 
When this is done, go to “File> Export> Data”. In the pop-up window, in the [Export file] view tick the 
box next to “Export to Spline Workspace”. Select the [Filter] tab and go to “Export annotations”. Use 
“Change filter” option as explained in 2.3.2 to ensure that the annotations you are interested in appear 
in the window. Select the “Rows” tab and click on “Single point select”. Select the “Splines” tab and 
select either Tongue, if you used the traditional splining way, or DLC_Tongue if you used the DLC 
splining method. Then click on Execute.  

You will now see your splines in the middle of Spline Workspace, see Fig. 55a, and their names will be 
displayed on the left-hand side. Depending on your research question you might want to compare: 

a) a single spline to another single spline; 
b) the splines of repetitions of one phone to repetitions of another phone; 
c) the splines of repetitions of one phone in one context to repetitions of the same phone in 

another context;  
d) or you might want to compare one set of phones to itself to see the amount of variability 

within the set.   

In this example we will go with option d) but the procedure is the same for the rest of the options. To 
measure mNND click on the spline name or click and drag to select multiple spline names, in the list 
on the left. If you need to select multiple non-adjacent splines you can click on one and hold Ctrl while 
clicking on the rest. This will be your first (group of) spline(s) which you will compare to another (group 
of) spline(s). In the bottom right corner select the “Functions” tab. Click on [Mean Nearest-Neighbour 
Difference]. You will see a pop-up prompting you to select your second (set of) spline(s) for comparison. 
Because in this example we are looking at the variability within this same set we don’t need to select 
anything new – our selection is already highlighted. Click on [Mean Nearest-Neighbour Difference] 
again. You will now see an MNND value pop under your annotations on the left. Click on it and you will 
find the mean and SD of NND in the top right-hand corner of the window. The window also contains 
the following message “A file has been created in your AAA folder called MSDs.txt which contains every 
MSD. You can copy-paste them into other software (eg., a spreadsheet or a statistics program).” You 
can also rename that file to use for later (repeating the mNND procedure will overwrite it) or copy and 
paste only the mean and SD values of interest.  
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Figure 55a: Spline Workspace  showing the selection of splines for which mean NND is being calculated by pressing the 
[Mean Nearest Neighbour Difference] button on the right. 

In the current versions of AAA up to V221.2.0 there is a bug. If you want to compare a set of splines to 
itself (option d) but your selection does not start from the top of the list (see Fig. 55b), you will get an 
error message when you click on Mean Nearest-Neighbour Difference for a second time. Alan Wrench 
is aware of it and hopefully it will be fixed in a future version. 

 

 
Figure 55b: Spline Workspace  showing the selection of splines for which mean NND is being calculated by pressing the 
[Mean Nearest Neighbour Difference] button on the right and the error message that appears if the procedure is carried 
out for splines that are not listed at the top of the list on the left. 

At the moment the workaround is to remove the splines above them from the Spline Workspace. Select 
the splines you want to remove. Click on the Options tab in the bottom right corner and then click on 
Delete. Now the splines of interest will appear at the top of the list and you can compare them to 
themselves. 
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4.6 Analyses beyond AAA, exporting spline coordinates and analyses 
You might want to carry out a custom spline analysis outside AAA, such as Modified Curvature Index 
(MCI) (Dawson et al., 2016), or Generalized Additive Mixed Models (GAMM) 
(https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms ). Or you might want to 
export the NINFL and DEI values for further testing in a statistical software. To carry out modified MCI 
or GAMM analyses, you will need to export the spline coordinates in a spreadsheet, and for further 
statistical testing you will need the NINFL or DEI values exported as well. The procedure is very similar 
to exporting annotations, as explained in 2.3.2. The steps up to Figure 18 are the same. Once you reach 
that stage, you might still want to export the Client, the sample time of row within recording, maybe 
the Keyword and Label, depending on what information you have included there. Don’t forget to click 
Add after you select every export-feature, and before clicking on a new feature, otherwise the new 
feature will override the old one you selected. 

To add NINFL and DEI information, click on the Analysis tab, see top of Fig. 56., then click on the analysis 
below (e.g., NINFL) and click Add. To add spline information, click on the Spline tab, see middle panel 
od Fig. 56, then click on the type of spline you want to export: [Tongue] for traditional fan splines, and 
[DLC_Tongue] for DLC splines. Then click on Value. Then you have a choice what type of information to 
export, depending on your needs. Radius-related information contains one datapoint per spline point, 
combining both height and backness of the tongue. X-Y coordinates contain two datapoints per spline 
point and allows you to differentiate between the two dimensions in your analyses. Click on [Execute].  

https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
https://stefanocoretta.github.io/phd-thesis/a-polar-gams.html#polar-gamms
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 Figure 56: Export windows showing the Spline Name (top) and Value (bottom) views of the Splines tab. 
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5. Scenarios 
These practice scenarios aim to demonstrate how you can integrate the tutorials above into concrete 
steps for answering research questions. 

5.1. Scenario 1: Comparing the variability of different articulations. 
You are interested in how much variation there is within the productions of two phones across 
repetitions. For example, you might want to find out if a more recently learned phone, such as a 
nonnative sound /θ/, has greater variability within a second language speaker’s articulations compared 
to a sound that has a close equivalent in their native language such as /t/. This can also apply in a 
speech therapy context – for example you might want to compare the variability of articulations in 
typically developing children and children with speech sounds disorders (Smith et al., 2023). 

• annotate /θ/ and /t/ in VCV position 

• fit tongue splines using the DLC method 

• export splines to Workspace 

• find the mean Nearest Neighbour Difference (mNND) of each (if you had more participants, 
you could see if the pattern persists across all of them using statistical comparisons: 
https://osf.io/3byvp/ ) 

• export a video of /θ/ and /t/ repetitions in slow motion to illustrate your results. 

5.2 Scenario 2: Finding if there is a difference between two average spline curves. 
You are interested if there is a systematic difference between the overall tongue shapes of two sounds, 
taking into account differences in both tongue height and backness. For example, in Bulgarian there is 
only an /i/ vowel, while in English there is a distinction between /i/ and /ɪ/. Are the lingual gestures for 
/i/ and /ɪ/ different at vowel midpoint for an L2 speaker of English with L1 Bulgarian? When you find 
out you can compare the results to a formant analysis at vowel midpoint.  

• annotate the /i/ and /ɪ/ vowel in single word recordings 

• fit tongue splines using the traditional method 

• export splines to Workspace, choosing vowel midpoint 

• produce mean and SD for each vowel and find the difference 

• run a t-test for the two vowel means

• export the mean and SD of each phoneme to Publisher 

• format and produce a plot to illustrate your findings 

• export the audio and annotations to textgrid for Praat to carry out acoustic analyses later 

5.3 Scenario 3: Comparing the number of inflections between two phones. 
You are interested if there is a difference in the number of inflections (a measure of tongue shape 
complexity) that two different phones have.  /r/ and /l/ tend to have the highest number of inflections 
in English. However, for an L1 Bulgarian- L2 English speaker an approximant /r/ might be challenging 
to produce and it might be produced with fewer inflections than /l/. The latter is produced similarly in 

https://osf.io/3byvp/
https://osf.io/3byvp/
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Bulgarian. Do the /r/ and /l/ phonemes have different tongue shape complexity compared to /a/ in this 
speaker?  /a/ can serve as a control because it is expected to have low NINFL.

• annotate the maximal lingual gesture of /r/ and /l/ and the midpoint of the stressed /a/ in the 
VCV productions 

• fit tongue splines using the using the DLC method 

• add the NINFL analysis 

• export the NINFL values for these annotations 

• if the data comes from one speaker only, you can use two paired t-tests in your statistical 
software of choice to compare /r/ to /a/ or /l/ to /a/.
(for a more complex statistical analysis, see here https://osf.io/9cwfg/ ) 

5.4 Scenario 4: Comparing the use of the tongue back in a velar and alveolar phone 
You are interested if a speaker is using the back of their tongue to achieve a velar sound appropriately 
(or overusing it inappropriately in cases of cleft palate-related speech errors). Does the /ŋ/ phoneme 
have higher dorsum excursion index than /n/ in this speaker? /ŋ/ isn't a phoneme in Bulgarian and it’s 
possible that this L2 speaker is producing it as an alveolar. You might also want to see if speakers who 
produce -ing sufÏxes as /ɪn/ differ in their use of tongue dorsum in the final consonant of “Colin” vs. 
“calling”. 

• annotate the maximal lingual gestures of /ŋ/ and /n/ phonemes in the VCV productions 

• fit tongue splines using the using the DLC method 

• add the DEI analysis 

• export the DEI values for these annotations 

• use a paired t-test in your statistical software of choice (if you have multiple consonants and 
speakers you can refer to this statistical analysis https://osf.io/2cp8e/ ) 

5.5 Scenario 5: Comparing the highest y-coordinate value between stressed and 
unstressed vowels 
You are interested if the tongue position for unstressed /i/ is less high than in stressed /i/ because 
stressed vowels tend to be more dispersed acoustically in English. The demo data is not ideal because 
the phonemic environment and context of the vowels are not controlled but you can still try for the 
sake of practice.  

• annotate the maximal lingual gesture of /i/ in stressed and unstressed position in single words 
and in the sentences. 

• fit tongue splines using a method of your preference 
• export the x-y coordinates (mm) 
• identify the highest y-value for each spline 

• carry out a t-test between the stressed and unstressed highest values  

https://osf.io/9cwfg/
https://osf.io/9cwfg/
https://osf.io/9cwfg/
https://osf.io/2cp8e/
https://osf.io/2cp8e/


41 AAA workshop 2023 

References 
Cleland, J., Dokovova, M., Crampin, L., & Campbell, L. (2023). An Ultrasound Investigation of Tongue 

Dorsum Raising in Children with Cleft Palate +/- Cleft Lip. The Cleft Palate-Craniofacial 

Journal: OfÏcial Publication of the American Cleft Palate-Craniofacial Association, 

10556656231158965. https://doi.org/10.1177/10556656231158965 

Dawson, K. M., Tiede, M. K., & Whalen, D. H. (2016). Methods for quantifying tongue shape and 

complexity using ultrasound imaging. Clinical Linguistics & Phonetics, 30(3–5), 328–344. 

https://doi.org/10.3109/02699206.2015.1099164 

Lawson E., Stuart-Smith J., Rodger L. (2019) A comparison of acoustic and articulatory parameters for 

the GOOSE vowel across British Isles Englishes. J Acoust Soc Am.146(6):4363. doi: 

10.1121/1.5139215. PMID: 31893717.

Dokovova, M., Sugden, E., Cartney, G., Schaefner, S., & Cleland, J. (2023). Tongue Shape Complexity in 

Children With and Without Speech Sound Disorders. Journal of Speech, Language, and 

Hearing Research. https://doi.org/10.1044/2023_JSLHR-22-00472 

Preston, J. L., McCabe, P., Tiede, M., & Whalen, D. H. (2019). Tongue shapes for rhotics in school-age 

children with and without residual speech errors. Clinical Linguistics & Phonetics, 33(4), 334–

348. https://doi.org/10.1080/02699206.2018.1517190 

Smith, A., Dokovova, M., Lawson, E., Kuschmann, A., & Cleland, J. (2023). A pilot fieldwork ultrasound 

study of tongue shape variability in children with and without speech sound disorder. 

https://pureportal.strath.ac.uk/en/publications/a-pilot-fieldwork-ultrasoundstudy-of-tongue-

shape-variability-in 

Zharkova, N. (2013). Using Ultrasound to Quantify Tongue Shape and Movement Characteristics. The 

Cleft Palate-Craniofacial Journal, 50(1), 76–81. https://doi.org/10.1597/11-196 

Zharkova, N., & Hewlett, N. (2009). Measuring lingual coarticulation from midsagittal tongue contours: 

Description and example calculations using English /t/ and /ɑ/. Journal of 

Phonetics, 37(2), 248–256. https://doi.org/10.1016/j.wocn.2008.10.005 

 


	Contents
	1.1 Opening a Project and Client.
	1.2 Resynchronisation, Field of View and Depth settings
	1.2.1 Resynchronisation
	1.2.2 Field of view and Depth settings
	2. Annotation and analysis
	2.1 The analysis tab
	2.2 Playing sound/UTI video recording and navigating
	2.3 Adding annotations
	2.3.1 Filtering annotations
	2.3.2 Exporting annotation data
	2.3.3 Exporting/importing annotations as Praat TextGrid with audio files
	3. Adding splines to a palate trace, bite plane trace, tongue surface and creating Client spline templates
	3.1 Adding fan-based splines
	3.2 Adding a fiducial spline to the bite-plane trace
	3.3 Making a fan-based spline template
	3.4 Adding keyframes
	3.5 Automatic tongue-spline fitting
	3.6 Tongue spline fitting using Deep Lab Cut (DLC) MD
	3.6.1 Converting fan-based splines to DLC splines and vice versa, and other spline batch processing
	3.6.1.1 Converting splines
	3.6.1.2 Other batch processes for splines; hiding and deleting splines
	3.7 Exporting splines to the workspace and publisher
	3.7.1 Exporting splines to the Workspace using Edit Splines
	3.7.2 Exporting splines to the Workspace using the Export function
	3.7.3 Exporting splines to Publisher
	3.8 Batch exporting videos
	3.8.1 To export a single video
	4. Spline analyses
	4.1 Mean and Standard Deviations in Workspace
	4.2 t-test between splines (fan-based and DLC)
	4.3 Number of INFLections (NINFL)
	4.4 Dorsum Excursion Index (DEI)
	4.5 Mean Nearest Neighbour Difference (mNND)
	4.6 Analyses beyond AAA, exporting spline coordinates and analyses
	5. Scenarios
	5.1. Scenario 1: Comparing the variability of different articulations.
	5.2 Scenario 2: Finding if there is a difference between two average spline curves.
	5.3 Scenario 3: Comparing the number of inflections between two phones.
	5.4 Scenario 4: Comparing the use of the tongue back in a velar and alveolar phone
	5.5 Scenario 5: Comparing the highest y-coordinate value between stressed andunstressed vowels
	References

